• Recent Questions
  • Popular Questions

Can any1 tell me if i should upgrade Pale Moon?


I keep getting a message in a pop-up box that says that I sld upgrade to 28.3.1.
Am i supposed to do this or sld i ignore it? & will I still be able to play my Java games if I upgrade it?
Thank u n advance!
lewie2011/Chrissy

    Answer from prinzdarian
    posted 1 month ago

    Pale Moon 28.3.1 has no problems playing Java games.

    Answer from lewie2011
    posted 1 month ago

    Ok thank u prinzdarian…do u suggest that i sld upgrade?
    Thank u for ur help!! lewie2011/Chrissy

    Answer from prinzdarian
    posted 1 month ago

    Yeah, it’s always recommended to use the latest version of a browser.

    The only exception I’ve found to that is turning off the update function in Firefox ESR 52.9 so that Firefox is still compatible with Java.

    Answer from lewie2011
    posted 1 month ago

    Ok good to know, cuz i haven’t been able to use my FF for some reason…maybe thats why. I have ESR, but maybe not the right version.
    Thanks so much prinzdarian

Answer this Question:

You must be logged in to post an answer. Signup Here, it takes 5 seconds :)

Other Questions